<div>Hi,<br></div><div><br></div><div>This is not an easy one-answer issue for me. I think you may have to try a few options and look deeper to try to find out what the real cause of the delays are.<br></div><div><br></div><div>A few areas to consider:<br></div><div>1. Maybe improve NFS at higher layers: look at udp vs tcp and NFS versions. Also rsize and wsize at mount.<br></div><div>2. Maybe improve NFS at lower layers: Are there any possible NIC or switch limits in play? If you do NFS over the same interface as the web or other services, and/or the snmp, could you dedicate a different NIC to NFS only.<br></div><div>3. Other ways of sharing storage? Perhaps experiment with iSCSI instead of NFS.<br></div><div>4. Consider other alternate options for collecting logs: Syslog supports logging to a remote syslog server for example. And many services like Apache that don't log to syslog by default can be configured to do so.<br></div><div><br></div><div>Sorry I don't have a quick or easy solution, but I hope the above provide food for thought.</div><div class="protonmail_signature_block protonmail_signature_block-empty"><div class="protonmail_signature_block-user protonmail_signature_block-empty"><br></div><div class="protonmail_signature_block-proton protonmail_signature_block-empty"><br></div></div><div><br></div><blockquote type="cite" class="protonmail_quote"><div>-------- Original Message --------<br></div><div>Subject: [sdnog] issues with high IO systems<br></div><div>Local Time: 28 November 2017 2:14 PM<br></div><div>UTC Time: 28 November 2017 10:14<br></div><div>From: samir.s.omer@hotmail.com<br></div><div>To: sdnog@sdnog.sd <sdnog@sdnog.sd><br></div><div><br></div><div> <br></div><div style="font-size:12pt;color:#666666;font-family:Calibri,Helvetica,sans-serif;" dir="ltr"><p style="margin-top:0;margin-bottom:0">Hi all<br></p><p style="margin-top:0;margin-bottom:0"><br></p><p style="margin-top:0;margin-bottom:0">I have 5 servers which are sharing an NFS monted storage for access logs. the log files are huge about 0.6 TB of Daily logs.<br></p><p style="margin-top:0;margin-bottom:0">my issue is that the shared storage is keeping the machines busy and not replying to my cacti snmp polling which keeps sending down alarms.<br></p><p style="margin-top:0;margin-bottom:0"><br></p><p style="margin-top:0;margin-bottom:0">any advice on how to go about this issue ?<br></p><div dir="ltr" style="font-size: 12pt; color: rgb(102, 102, 102); font-family: Calibri, Helvetica, sans-serif, "EmojiFont", "Apple Color Emoji", "Segoe UI Emoji", NotoColorEmoji, "Segoe UI Symbol", "Android Emoji", EmojiSymbols;"><p style="margin-top:0; margin-bottom:0"><br></p><p style="margin-top:0; margin-bottom:0"><br></p><div><span style="font-family:Calibri" class="font"><span style="color:#666666" class="colour">Regards,</span></span><span style="font-family:Calibri" class="font"><span style="color:#666666" class="colour"><br> </span></span><span style="font-family:Calibri" class="font"><span style="color:#666666" class="colour">Samir</span></span></div></div></div></blockquote><div><br></div>